Excel 2016 – Data Manipulation

Table of Contents

Text Functions .................................................................................................................................................. 2
Left Formula .................................................................................................................................................. 2
Right Formula ............................................................................................................................................... 2
Find Formula ................................................................................................................................................ 2
Len Formula .................................................................................................................................................. 2

Combining Text Functions ............................................................................................................................ 3

Date Functions ............................................................................................................................................... 3
Day Function .................................................................................................................................................. 4
Month Function ............................................................................................................................................. 4
Year Function ................................................................................................................................................. 4

Importing Text Files to Excel ....................................................................................................................... 4
Text Import Wizard ....................................................................................................................................... 5

Massaging the Data ......................................................................................................................................... 6
Social Security Number ................................................................................................................................. 6
Additional Number Formats ........................................................................................................................ 7
The Proper Function .................................................................................................................................... 7
The Lower Function ..................................................................................................................................... 8
Trim Function ............................................................................................................................................... 9
Upper Function ........................................................................................................................................... 9

Cell References ............................................................................................................................................. 9
Relative Cell References .............................................................................................................................. 9
Absolute Cell References ............................................................................................................................ 10

IF Statements ................................................................................................................................................ 10

Dropdown Lists ............................................................................................................................................. 11
Text Functions
Formulas are normally associated with numbers, however there are formulas that can aid with text too.

Left Formula
The LEFT function will look into a specific cell and pull out text starting from the left hand side of the cell and counting a certain number of characters over.

Right Formula
The RIGHT function will look into a specific cell and pull out text starting from the right hand side of the cell and counting a certain number of characters over.

Find Formula
The FIND function will locate one text string within a second text string, and return the number of the starting position of the first text string from the first character of the second text string.

Len Formula
The LEN function returns the number of characters in the specified string.

Note: Spaces count as a character with this formula
Combining Text Functions
While the functions mentioned above are useful, they become powerful when used together. In the above example, the formula produced for the first person would not work for the second person.

Combining the text functions mentioned above allows for the creation of a robust formula that can separate first and last names.

First Name
The trick to pull out just the first name is to utilize the “space” between the first and last name. The following two functions will be used for the first name:

- LEFT
- FIND

Last Name
The same trick for last name is utilized, however this will require use of the LEN function:

- RIGHT
- FIND
- LEN

Date Functions
Excel also has functions that pull out information of dates. If information is in the mm/dd/yyyy format or any other date format, each section of the date can be pulled out with the following functions:

- DAY
- MONTH
- YEAR
Day Function
This function returns the day of a date. The day is given as an integer ranging from 1 to 31.

<table>
<thead>
<tr>
<th>Name</th>
<th>DOB</th>
<th>FirstName</th>
<th>LastName</th>
<th>Day</th>
<th>Month</th>
</tr>
</thead>
<tbody>
<tr>
<td>Brad Pitt</td>
<td>12/18/1963</td>
<td>Brad</td>
<td>Pitt</td>
<td>18</td>
<td>12</td>
</tr>
<tr>
<td>Angelina Jolie</td>
<td>6/4/1975</td>
<td>Angelina</td>
<td>Jolie</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Month Function
This function returns the month of a date. The month is given as an integer, ranging from 1 (January) to 12 (December).

<table>
<thead>
<tr>
<th>Name</th>
<th>DOB</th>
<th>FirstName</th>
<th>LastName</th>
<th>Day</th>
<th>Month</th>
<th>Year</th>
</tr>
</thead>
<tbody>
<tr>
<td>Brad Pitt</td>
<td>12/18/1963</td>
<td>Brad</td>
<td>Pitt</td>
<td>18</td>
<td>12</td>
<td>1963</td>
</tr>
<tr>
<td>Angelina Jolie</td>
<td>6/4/1975</td>
<td>Angelina</td>
<td>Jolie</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Year Function
This function returns the year corresponding to a date. The year is returned as an integer in the range 1900-9999.

<table>
<thead>
<tr>
<th>Name</th>
<th>DOB</th>
<th>FirstName</th>
<th>LastName</th>
<th>Day</th>
<th>Month</th>
<th>Year</th>
</tr>
</thead>
<tbody>
<tr>
<td>Brad Pitt</td>
<td>12/18/1963</td>
<td>Brad</td>
<td>Pitt</td>
<td>18</td>
<td>12</td>
<td>1963</td>
</tr>
<tr>
<td>Angelina Jolie</td>
<td>6/4/1975</td>
<td>Angelina</td>
<td>Jolie</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Importing Text Files to Excel
There are instances when data is collected and the information is in text format as in the example below:

Excel has an automatic feature that allows for the import of data separated by delimiters (in this case the data is separated by commas).

In order for this to work, the data must be opened from within Excel.
If you do not see your data file, select the dropdown menu that says **All Excel Files** and change it to **All Files**.

Double click the text file.

---

**Text Import Wizard**

Excel recognizes that this file is not the standard Excel format. Because of this, Excel opens up the Text Import Wizard.

The first option is to determine how the data is arranged. In this case, the data is **Delimited** by commas. In other words, each column is separated by commas.

The next option is to select the checkbox that says **My data has headers**.

Select **Next**.

The delimiter must now be set. The data in this example is delimited with commas.

Once the proper delimiter has been selected, click “Next”.

---
Before the import wizard will import your data, the option is available to set the formatting of each column. Simply click the column to be formatted and select the proper radio button at the top. A column can also be ignored should it not need to be imported.

Once everything is properly formatted, click Finish.

The data should now be separated into columns. However, the data has some problems.

Massaging the Data

The data that was just imported needs to be formatted still. Excel comes with tools to help make the data look more presentable.

Social Security Number

The Social Security Number field is not formatted properly. This can be fixed by:

1. Highlighting the data
2. Right clicking the data
3. Select Format Cells
4. Select Special
5. Choose Social Security Number
6. Select OK

The data should now be formatted properly.
Additional Number Formats
There is a variety of number formats that are available. Using the instructions above, format the Home Phone and Postal Code columns.

The Proper Function
The Proper function to correct the data that is imported as all lower case or upper case.

A column can be inserted to create the equation.

After this equation is entered, it is copied down to the cells below using auto-fill.
Copying Over the Data

The data that was just created must replace the original information.

To do this highlight the information and right-click to display the quick access menu and select **Copy**.

In the original Last Name column, place the cursor where the first cell for names is, right-click and select the **Paste Values** option (should be the second icon with a clipboard and 123).

This places the formula responses, without the formula, into the cells.

Repeat this method with the Middle Name and the First Name columns using the column that was inserted for last name.

Once the values of the columns have been pasted to the original location, the column with the formula can be deleted.

The Lower Function

If there are capital letters that need to be in lower case, the **Lower** function will convert the data. Like the Proper function, insert a new column for this formula.

Copy the information to the rest of the cells

Move the information as in the previous section using the **Copy** and **Paste Values** functions.
**Trim Function**

If there are extra spaces in the text field, the Trim function will get rid of them.

Copy the information to the rest of the cells

Move the information as in the previous section using the right mouse button.

**Upper Function**

The Upper function converts text to uppercase.

Copy the information to the rest of the cells.

Move the information as in the previous section using the right mouse button.

**Cell References**

**Relative Cell References**

By default, all cell references are relative references. When copied across multiple cells, they change based on the relative position of rows and columns.

When copied down, the formula now references the corresponding cells.
Absolute Cell References

There may be times when the cell reference must be absolute. Unlike relative references, **absolute references** do not change when copied or filled. Use an absolute reference to keep a row and/or column **constant**.

An absolute reference is designated in a formula by the addition of a **dollar sign ($)**. The F4 key can be used to make a cell absolute as well.

Right now, the G2 cell is relative. To make it absolute, highlight the **G2** text and press **F4**. Press **Enter** to complete the formula.

<table>
<thead>
<tr>
<th>G</th>
<th>2</th>
<th>Total Points</th>
<th>Percentage</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>76</td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>71.9</td>
<td>=G3/G2</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>52.6</td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>66.7</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Copying the formula down will apply it to the rest of the cells. However, the G2 cell reference remains the same for each copy.

**IF Statements**

If statements are another function in Excel. They return one value if a condition specified evaluates to **TRUE** and another value if it evaluates to **FALSE**.

For example, a grade sheet is placed in Excel and formulas are used to calculate final percentages. Excel can look at the percentages and tell us whether an individual passed or failed a class.

The formula reads: If the contents in cell H3 are greater than 70%, then return a value of “Pass” and if the contents of cell H2 are not greater than 70% return a value of “Fail”.

Copying the formula down will apply the formula to the other cells.
Dropdown Lists
Sometimes it is easier to have users select from a list of options as opposed to typing freely in a cell.

With a cell selected, go to the Data Validation options in the Data tab.

For the Allow section, select List option from the dropdown menu.

In the Source field, type “Yes, No”. This is what populates the dropdown list.

Press OK.
# Excel 2016 – PivotTables and Charts

## Table of Contents

- What is a PivotTable? .................................................................................................................. 2
- Creating a PivotTable .................................................................................................................. 2
- Pivoting a PivotTable .................................................................................................................... 3
- Formatting the PivotTable ............................................................................................................. 4
- Changing the Data Appearance ..................................................................................................... 4
- Viewing the Data ........................................................................................................................... 4
- Analyze the Data .......................................................................................................................... 5
- Filters ........................................................................................................................................... 5
- Slicers ........................................................................................................................................... 5
- Timelines ...................................................................................................................................... 6
- Data Details .................................................................................................................................. 7
- Updating PivotTable ...................................................................................................................... 7
- Additional PivotTable Options ...................................................................................................... 8
- Clear ............................................................................................................................................ 8
- Select .......................................................................................................................................... 8
- Creating a PivotChart .................................................................................................................... 8
- Formatting a PivotChart ................................................................................................................ 9
- Changing Chart Type .................................................................................................................... 10
- Analyzing the PivotChart ............................................................................................................. 10
- Filters .......................................................................................................................................... 11
- Slicers and Timelines .................................................................................................................... 11
- Chart Templates ........................................................................................................................... 11
- PowerPivot .................................................................................................................................. 11
- Data Sources ............................................................................................................................... 13
- Formatting Data Sources .............................................................................................................. 14
- Creating Relationships ................................................................................................................ 14
- Creating a PivotTable in Power in PowerPivot ........................................................................... 14
What is a PivotTable?
A PivotTable allows data to be summarized and more manageable and also provides a variety of ways to manipulate the data. It can instantly calculate and summarize data in a way that is easy to read and re-arrange (also known as pivoting) to provide answers to different questions.

Creating a PivotTable
In order to create a PivotTable, the data in the spreadsheet does not need to have any gaps or blank rows or columns in it. Place the cursor in a cell that will be included in the PivotTable and select PivotTable from Tables group of the Insert tab.

The Create PivotTable box appears.

The first section is the data range that should be included in the PivotTable. Excel typically will select the entire range of data; however, if not or if a different range needs to be selected, the arrow to the right of the selection can be clicked and a different range highlighted.

The next section is where the PivotTable is to be placed: in a new worksheet or the existing worksheet. It is usually recommended to place a PivotTable in a new worksheet so the PivotTable can be standalone for any rearranging that may be done to it and ensure the original data is not disturbed.

One these selections have been made, select OK.

As with many other options in Excel, a PivotTable Tools tab is added to the Ribbon with an Analyze and a Design tab.

On the right side of the screen is the PivotTable Fields Pane. This pane is where the PivotTable will be created and pivoted (rearranged).

The top section is the fields available to include in the PivotTable.

The bottom section is where the fields are arranged to produce the PivotTable.

The fields can be moved to the areas of the PivotTable in the bottom section of pane until the desired view/report is received.
Pivoting a PivotTable
The fields can be moved to the different sections of the PivotTable to create a different look or even a new PivotTable. To do this, click and drag the field from one section to another.
Formatting the PivotTable

Changing the Data Appearance

With the data in the PivotTable, there are a variety of options available for the data by right-clicking on a cell within the PivotTable. For example, numbers can be formatted and information can be sorted. Using the **Summarize Values By** option produces additional options other than **Sum**, such as **Count, Average, Minimum,** and **Maximum.** **Show Value As** provides options for displaying the information such as using percentages, ranking the information, and differences from other information in the table.

Viewing the Data

Excel provides a couple of options for the way the information is viewed. These options can be found in the **Layout** group of the **Design** tab.

The way **Subtotals** and **Grand Totals**, as well as the **Report Layout** and **Blank Rows** can be changed based on user preference. These options can be found in the **Layout** group of the PivotTables **Design** tab.

Row and Column headers, as well as banded rows and columns can also be selected if desired from the **PivotTable Style Options** group.

There are also a variety of other PivotTable Styles that can be selected.
Analyze the Data

Filters
Just like in a normal Excel worksheet, PivotTables can be filtered to view only selected data. Filtering can be done a couple of ways.

The first way is similar to a normal worksheet, using the drop down arrows for the row and column headers. Just place a checkmark in the selection(s) for that field to be viewed. When done using the filters, select the drop down arrow by the field name again, and choose Clear Filter from....

The other way to filter data is in the PivotTable Fields pane. There is a small drop down arrow when you hover over the field name.

You can clear the filter in a similar way as the previous method, select the drop down arrow next to the field, and select Clear Filter from....

Slicers
Slicers provide another way to filter the data, but do it in a way that is friendlier to the viewer and can be used to demonstrate information to others. To insert a slicer, select Insert Slicer from the Filter group on the PivotTable Tools Analyze tab.

The Insert Slicers dialogue box open and a check should be place in each field to be sliced (filtered).

A Slicer box appears on screen, as well as a new Slicer tab with formatting options for the Slicer.
To view a particular selection of the slicer, just click that selection and only that selection’s information will be viewed in the PivotTable. You can view more than one by holding the shift button and selecting each option to be viewed. More than one slicer can be selected at a time also.

Slicers have their own settings and formatting options. They can have their own styles and be re-sized, as well as have more than 1 column if preferred. Slicers also have their own settings under Slicer Settings or by right clicking on the slicer and selecting Settings. Settings include caption, sorting order, as well as how to handle items with no data.

When the individual selections are no longer needed, click on the X on the filter in the upper right corner of the slicer and when the slicer is no longer needed, select the border of the slicer and select Delete. Also, right-clicking on the slicer and selecting Remove Slicer will remove it.

**Timelines**

A Timeline allows the information in the PivotTable to be viewed based on a timeframe, if the date is included in the data for the PivotTable. A timeline is also a tool that is great for visual purposes. To use a timeline, select Insert Timeline from the Filter group of the PivotTable Tools Analyze tab. An Insert Timelines box will appear with the field options with dates to select from. Check the appropriate field and select OK.

Once that is done, the Timeline appears. Like slicers, you can click to select and de-select timeframes to review and the PivotTable will update with information for timeframe selected.
Using the **Shift** + option, multiple dates can be selected; however, the dates have to be consecutive.

Like the slicer, the Timeline also has its own tab with various options such as styles, labels, and sizes.

When the individual selections are no longer needed, click on the X on the filter in the upper right corner of the timeline and when the Timeline is no longer needed, select the border of the timeline and select **Delete**. Also, right-clicking on the timeline and selecting **Remove Timeline** will remove it.

**Data Details**

In the event it is necessary to view the information that makes up a particular area of a PivotTable, double-clicking on the cell will create a new worksheet that shows what rows or columns made up that particular cell of the PivotTable.

**Updating PivotTable**

In the event the source data for a PivotTable changes, the PivotTable can be updated using the **Refresh** option in the **Data** group of the **PivotTable Tools Analyze** tab.
Additional PivotTable Options

Clear
If there comes a time when a particular PivotTable is no longer needed, the PivotTable can be cleared using the Clear option in the Actions group of the PivotTable Tools Analyze tab.

Select
In the event the PivotTable needs to be selected, you can select the entire table by using the Select option, also found in the Action group of the PivotTable Tools Analyze tab. This can be used to copy and paste the PivotTable if need be.

Creating a PivotChart
Similar to standard charts in Excel, PivotCharts are an image that represents data in a PivotTable. They are created very similar to a PivotTable. To create a PivotChart, select a cell within the data and select PivotChart from the Charts group on the Insert tab.

Similar to a PivotTable, a Create PivotChart dialogue appears with options for data range and location for the PivotChart.

Once those selections are made, click OK.

In the location selected for the chart, a PivotChart Fields pane, which looks very similar the pane for PivotTables will appear, along with an area for a PivotTable and Chart. As with the PivotTable, the fields can be moved to the areas of the chart in the bottom portion of the Fields pane.
Also, a **PivotChart Tools** tab with an **Analyze**, **Design** and **Format** tab is now available to help format the chart.

As fields are moved to the chart areas, the PivotChart is created, as well as a PivotTable that coordinates with the chart.

**Formatting a PivotChart**

Similar to the regular charts in Excel, using the **Design** tab of the **PivotChart Tools** tab allows the charts colors and styles to be changed. Also, by clicking inside the chart, additional options become available on the right side of the chart. Double-clicking on various elements of the chart also opens up additional formatting panes on the right side of the screen.
The **Format** tab of the PivotChart Tools tab provides formatting options for the various areas of the chart as well.

Changing Chart Type

The Chart Type can be changed by selecting the **Change Chart Type** option from the **Design** tab of the PivotChart Tools tab.

Again, similar to regular charts in Excel, there are a variety of options and the Change Chart Type dialogue box provides previews of each chart type.

Analyzing the PivotChart

Like PivotTables, PivotCharts have options such as **Filters**, **Slicers**, and **Timelines**.
Filters
The filter feature can be utilized in the **PivotChart Fields** pane or the chart using the dropdown arrows beside the field name.

Slicers and Timelines
Slicers and Timelines can be used as well. Like PivotTables, they are great for visual aids and can be found in the **Filter** group of the **Analyze** tab of the **PivotTables Tools** tab.

Chart Templates
Once a chart is created, that design can be saved as a template to be used at a later time. To do that, right click on the chart and select **Save as Template**.

A **Save Chart Template** dialogue box appears and the chart can be named and saved.

To access the template in the future, select **Change Chart Type** from the **Design** tab of the **PivotChart Tools** tab. In the **Change Chart Type** dialogue box, there is a **Templates** option, and the saved template should be in that folder.

PowerPivot
Historically, PivotTables only allowed data sources to come from only one worksheet or table; however, with Office Professional 2013, that changed! PowerPivot now allows multiple data
sources to be used for PivotTables by using relationships between the data sources. PowerPivot must first be turned on. To do that, go to the Backstage view and choose Options.

From the Options dialogue box, select Add-Ins. At the bottom of the box, there is a Manage drop down menu. Select COM Add-ins and Go.

From the COM Add-Ins, a check needs to be placed in the check box for Microsoft Office PowerPivot for Excel 2013 and select OK.

Excel has now placed a PowerPivot tab on the ribbon.
Data Sources

There are multiple ways to add data sources to PowerPivot. If working with an existing Excel spreadsheet, select a cell that contains data and simply select **Add to Data Model** from the **Tables** group on the **PowerPivot** tab.

The **Create Table** dialogue box appears with the location of the source data. Confirm that that location is inclusive of all the data to be included and if there are column headings, make sure and check the box for "My table has headers" and select **OK**.

Excel places that data in a new table in a PowerPivot window that looks very similar to Excel. There are fewer tabs, and some tabs and options are different than Excel.

To go back to the data source to add the other worksheet to PowerPivot, select the small Excel icon at the upper left part of the screen.
PowerPivot offers a variety of options of adding data sources to the data model.

To add from other sources, select which option is needed using the options in the Get External Data group in the Home tab of the PowerPivot window.

As other data sources are added to PowerPivot, more tables will be added, similar to worksheets being added in Excel.

**Formatting Data Sources**

Once the data sources have been added, columns can be formatted if need be. There are not as many formatting options in the PowerPivot view. The formatting options are in the Formatting group on the Home tab of the PowerPivot window.

**Creating Relationships**

In order for the data sources to “talk” to each other for a PivotTable, a relationship between the tables has to be created. To create a relationship, select Create Relationship from the Relationships group of the Design tab. The Create Relationship dialogue box appears.

In this box, identify what columns from each table relate to each other. In this example, the Month column in Table 1 needs to relate to the ID column in Table 2. Select Create when done.

At the top of the column, a new icon appears on the Month column indicating that column has a relationship.

**Creating a PivotTable in Power PowerPivot**

Once the relationships have been created, the PivotTable with the multiple data sources can be created. To create a PivotTable in PowerPivot, select PivotTable from the Home tab. There are several options for creating Pivot objects using the drop down option also. When PivotTable is selected, it will transition back to Excel and ask if the PivotTable should be created in a New Worksheet or Existing Worksheet.

Once the selection is made, the Excel window will look very similar to creating standard PivotTables, but in the PivotTable Fields pane, the tables from PowerPivot will be listed now.
As with standard PivotTables, fields can be moved to the different sections of the PivotTable until the desired layout is achieved. The difference now is that with the relationship created between the two tables, fields from two or more tables can be integrated into the PivotTable.

All the tools available previously in PivotTables and Charts are still available with the PowerPivot table.
# Excel 2016 – Advanced

## Table of Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Charts</td>
<td>3</td>
</tr>
<tr>
<td>Column Chart/Bar Chart</td>
<td>3</td>
</tr>
<tr>
<td>Creating the Chart</td>
<td>3</td>
</tr>
<tr>
<td>Chart Styles and Colors</td>
<td>4</td>
</tr>
<tr>
<td>Other Options</td>
<td>5</td>
</tr>
<tr>
<td>Pie Charts</td>
<td>7</td>
</tr>
<tr>
<td>Arranging Data</td>
<td>8</td>
</tr>
<tr>
<td>Moving the Data</td>
<td>8</td>
</tr>
<tr>
<td>Entering the Formulas</td>
<td>9</td>
</tr>
<tr>
<td>Total Sales</td>
<td>9</td>
</tr>
<tr>
<td>Total Income</td>
<td>9</td>
</tr>
<tr>
<td>Total Revenue</td>
<td>10</td>
</tr>
<tr>
<td>Total Expenses</td>
<td>10</td>
</tr>
<tr>
<td>Profit/Loss</td>
<td>10</td>
</tr>
<tr>
<td>Other Formulas</td>
<td>10</td>
</tr>
<tr>
<td>Sum</td>
<td>10</td>
</tr>
<tr>
<td>Average</td>
<td>10</td>
</tr>
<tr>
<td>Count</td>
<td>11</td>
</tr>
<tr>
<td>Max</td>
<td>11</td>
</tr>
<tr>
<td>Min</td>
<td>11</td>
</tr>
<tr>
<td>Round</td>
<td>11</td>
</tr>
<tr>
<td>IF</td>
<td>12</td>
</tr>
<tr>
<td>CountIf</td>
<td>12</td>
</tr>
<tr>
<td>Absolute Cell References</td>
<td>12</td>
</tr>
<tr>
<td>Conditional Formatting</td>
<td>13</td>
</tr>
<tr>
<td>Color Scales</td>
<td>13</td>
</tr>
<tr>
<td>Top/Bottom Rules</td>
<td>13</td>
</tr>
<tr>
<td>Custom Conditional Formatting</td>
<td>14</td>
</tr>
<tr>
<td>Vlookup</td>
<td>15</td>
</tr>
<tr>
<td>Arrays</td>
<td>16</td>
</tr>
<tr>
<td>Array Example</td>
<td>17</td>
</tr>
<tr>
<td>Array Formulas</td>
<td>17</td>
</tr>
<tr>
<td>Advanced Array Formulas</td>
<td>17</td>
</tr>
</tbody>
</table>
Charts
Charts are visual representations of data. Charts allow the audience to see numbers in graphic form. This makes conveying information easier if done properly. There are many types of charts.

Column Chart/Bar Chart
Bar graphs or "column charts" as they are known in Excel are most often used to show amounts or the number of times a value occurs.

The amounts are displayed using a vertical bar or rectangle. The taller the column, the greater number of times the value occurs.

No matter what type of chart is used, data is required as a reference for the measurements

Creating the Chart
First, highlight all data that will be referenced in the chart

Then, go to the Insert tab. Under the Charts group there will be an icon with vertical bars. When clicked, there will be more options available. Select the first option under 2-D column.
The chart will look like the chart to the right initially.

Double-click on the title and change the name to “All Time Box Office Receipts”.

**Chart Styles and Colors**
The initial design of the chart can be altered. Excel comes with several different styles for charts.

To access these Styles do the following:

1. Click on the chart
2. Go to the **Design** tab under **Chart Tools**
3. Under the **Chart Styles** group, select the chart style and watch the chart change

In this example, Style 9 has been selected.
To change the color scheme of the bars, go to **Change Colors** under the **Design Tab** and select the desired color scheme.

**Other Options**
There are other chart options that can be adjusted.

**Chart Area**
If the chart area (chart background) needs to be updated, double-click on the area underneath the bars.

When this is done, the right hand side of Excel will change to display Chart Area Options.
To change the background, select the Solid Fill radio button.

Under **Color**, select the desired color.

Here is what the chart now looks like.

**Axis Options**

The axis of the chart can also be updated in the same way.

Select the axis to be formatted double-clicking.

Underneath the **Axis Options** (icon looks like a bar graph) the above options are shown.

Change the display units to “Billions”.

The chart will now show the vertical axis in billions.
Pie Charts

Pie charts show the size of items in one data series, proportional to the sum of the items. The data points in a pie chart are displayed as a percentage of the whole pie.

Pie charts can only plot one set of data at a time. In this case, only Graduate Students are selected.

Then, go to the **Insert** tab. Under the **Charts** group there will be an icon that looks like a circle. When clicked, there will be more options available. Select the first option under 2-D pie.

Similar to the bar chart, the elements of the pie chart, as well as any other chart can be formatted.
Arranging Data

Data is good, but if it is unorganized it will not benefit anyone. In this example, the data is jumbled and hard to read.

Moving the Data

Move the “Profit/Loss” cell to cell A30. This is done by clicking on the cell and hovering over the edge of the cell until the cursor changes. Once it changes, click and drag to cell A30.

The “Total Expenses” columns will be moved to cell A29.

The section pertaining to variable expenses will be moved next. Highlight everything from “Variable Expenses” to the final cell in the “Projector Running Costs” row.

Move the entire selection to cell A25.

Continue to move the data until it looks like the example below.
Entering the Formulas
This spreadsheet is now ready for formulas

**Total Sales**
In cell B7, enter the following equation: \(=B5+B6\)

Copy the formula over by dragging the fill handle (little cross at the bottom right corner of the cell).

**Total Income**
Enter the following formula in cell B13: \(=\text{SUM}(B10:B12)\)

Copy the formula over by dragging the fill handle across the other cells in the row.
Total Revenue
In cell B15, enter the following formula: =SUM(B13, B7)
Copy the formula over by dragging the fill handle across the other cells in the row.

Total Expenses
Enter the following formula in the cell B29:
=SUM(B21:B23,B26:B27)
Copy the formula over by dragging the fill handle across the other cells in the row.

Profit/Loss
In cell B30 type this formula: =B15-B29

Other Formulas
Sum
The \textbf{SUM} function adds all the numbers that you specify as arguments. Each argument can be a range, a cell reference, an array, a constant, a formula, or the result from another function. For example, =SUM(A1:A5) adds all the numbers that are contained in cells A1 through A5. For another example, =SUM(A1, A3, A5) adds the numbers that are contained in cells A1, A3, and A5.

Enter the formula: =SUM(B2:B9)

Average
Returns the average (arithmetic mean) of the arguments. For example, if the range A1:A20 contains numbers, the formula =AVERAGE(A1:A20) returns the average of those numbers.

Enter the formula: =AVERAGE(B2:B9)
Count
The COUNT function counts the number of cells that contain numbers, and counts numbers within the list of arguments. Use the COUNT function to get the number of entries in a number field that is in a range or array of numbers.

Enter the formula: =COUNT(B2:B14)

Max
The MAX function returns the largest value in a set of values.

Enter the following formula:
=MAX(B2:B14)

Min
The MIN function returns the smallest number in a set of values.

Enter the following formula:
=MIN(B2:B14)

Round
The ROUND function rounds a number to a specified number of digits. Since it is not a formula for a range of cells, the auto-fill feature can be used to copy the formula to other cells.

=ROUND(B2,0)
**IF**
The IF function returns one value if a condition you specify evaluates to TRUE, and another value if that condition evaluates to FALSE. The auto-fill feature can be used to copy the formula to other cells in the column.

Enter the following formula: =IF(B4>=50, “Pass”, “Fail”)

**CountIf**
The COUNTIF function counts the number of cells within a range that meet a single criterion that you specify. For example, you can count all the cells that start with a certain letter, or you can count all the cells that contain a number that is larger or smaller than a number you specify.

Enter the following formula: =COUNTIF(C2:C13, “Pass”)

**Absolute Cell References**
The autofill option in Excel provides a way to copy formulas in a column, without the need for copy and paste. The formula adjusts as it moves down the column to incorporate the values of the row in the formula.

There may be times when the cell reference must be absolute. Unlike relative references, absolute references do not change when copied or filled. Use an absolute reference to keep a cell reference constant.

An absolute reference is designated in a formula by the addition of a dollar signs ($), to the cell reference. The F4 key can be used to make a cell absolute as well.
Enter the following formula:

=G3/$G$2

Conditional Formatting
By applying conditional formatting to your data, you can quickly identify variances in a range of values with a quick glance. Conditional formatting can also be used to format cells based on the contents entered into the cell.

Color Scales
Color scales will format all of the data that is selected. Smaller numbers will be closer in color and the gradient will begin to shift as numbers get higher.

Select the data to format.

Apply the conditional formatting under:

Home Tab > Styles Group > Conditional Formatting

Apply the “Red, White and Blue Color Scale”

Here is the result:

The colors will update as the numbers are changed.

Top/Bottom Rules
Conditional formatting can also be used to detect the highest or lowest set of numbers in a dataset.

Select the data to format.

Apply the conditional formatting under:

Home Tab > Styles Group > Conditional Formatting > Top/Bottom Rules
Apply the “Top 10 Items...” format

The following pop up will result:
The formatting can be changed as well as the number of cells to highlight.

Select OK.
The cells with the 10 highest numbers will be highlighted.

Custom Conditional Formatting
Custom rules can be created. To create a new rule, go to

*Home Tab > Styles Group > Conditional Formatting > New Rule*

The following pop up will appear.

Options can then be created based on cell contents and how cells should be formatted. Rules can be created for an entire column prior to cell input to allow the cell to format as soon as input is entered into the cell.
Vlookup

VLOOKUP is a fantastic tool that can turn a spreadsheet into a database. The VLOOKUP function searches the first column of a range of cells, and then returns a value from any cell on the same row of the range.

Syntax

As with any formula, to start a VLOOKUP, enter the equals signs (=) and follow it with VLOOKUP

- **lookup_value** – Required. The value to search in the first column of the table or range. The lookup value can be a cell reference or an actual value
- **table_array** – Required. The range of cells that contains data. You can use a reference to a range (for example, A2:D8), or a range name. The values in the first column of **table_array** are the values searched by **lookup_value**. These values can be text, numbers, or logical values. Uppercase and lowercase text are equivalent.
- **col_index_num** - Required. The column number in the **table_array** argument from which the matching value must be returned. A **col_index_num** argument of 1 returns the value in the first column in **table_array**; a **col_index_num** of 2 returns the value in the second column in **table_array**, and so on.
- **range_lookup** - Optional. A logical value that specifies whether you want VLOOKUP to find an exact match or an approximate match

In the example above, the discount table on the right can be used to fill in the data in the % Discount column. The formula should look like this:

Enter the following formula: =VLOOKUP(A8,$H$8:$I$16,2,True)
After the formula is copied down, it will pull the corresponding percentage into each cell according to how many units were purchased.

The VLOOKUP formula can be used to populate grades too.

Here is an example of a gradesheet. The students will get a grade depending upon the scale on the right.

Be sure to freeze the reference table and press "Enter".

Copy the information to every cell below to have the formula to each person.

**Arrays**

An array is a collection of data. These can also be referred to as tables. Array formulas are explored in this section.
Array Example
This can be classified as an array.

Array Formulas
Formulas can be used on arrays. If the sum of all the items is desired, enter the SUM formula and select the array.

This same procedure can be used for multiplication.

Advanced Array Formulas
Suppose that the average change between pre and post tests for an entire class is desired. This would normally be a multistep process. However, with arrays this can be done in one step.

This formula is not complete. If Enter is pressed at this point, the above will result which is incorrect. Prior to hitting Enter, press CTRL + SHIFT + ENTER. This will tell Excel that this is an array formula. When CTRL + SHIFT + ENTER is pressed, the formula will be surrounded by brackets \{formula\}.
Array Formulas with IF Statements

Array formulas can be quite robust when combined with IF statements. Suppose that a specific demographic average is required, such as the average change in male freshman.

This formula is averaging the difference between the post-test and the pre-test. But it is only doing so for individuals who are male freshman.

Pressing CTRL+SHIFT+ENTER will give us the following result:

If the average change for female freshman is desired, change the “Male” to “Female in the formula.

Using Dropdown Menus with Advanced Array Formulas

In the previous example, the data was changed when the formula was edited. However, the formula results can be changed more quickly if dropdown menus are used.

Creating A Dropdown Menu

On the Data tab, go to Data Validation in the Data Tools group. A Data Validation dialogue will appear.

Change the “Allow” dropdown menu to “List”

Select the button to the right of the Source text entry box.

Select a set of classification names (Freshman, Sophomore, Junior, Senior) and press Enter. The options can also be typed into the Source area.

Press OK
A dropdown list has now been created in that cell.

**Updating Your Array Formula**

The array formula must now be updated.

With the old formula open, delete the word “Freshman” and “Male” and select the cell that has the dropdown menu.

Press **CTRL+SHIFT+ENTER**

Now, selecting the classification will automatically update the average!